MOAC 70-410 - Installing and Configuring Windows Server 2012 R2 Lab Manual		
Lab 2
Configuring Servers
THIS LAB CONTAINS THE FOLLOWING EXERCISES AND ACTIVITIES:
	Exercise 2.1
Exercise 2.2
Exercise 2.3
Lab Challenge
	Completing Post-Installation Tasks

Adding Roles and Features 
Converting the GUI Interface to Server Core 

Using the Server Core Interface


BEFORE YOU BEGIN
The lab environment consists of computers connected to a local area network, along with a server that functions as the domain controller for a domain called adatum.com. The computers required for this lab are listed in Table 2-1.
Table 2-1
Computers Required for Lab 2
	Computer
	Operating System
	Computer Name

	Domain controller
	Windows Server 2012 R2
	SERVERA

	New member server 
	Windows Server 2012 R2
	SERVERB

	Member server 
	Windows Server 2012 R2
	SERVERC



In addition to the computers, you also require the software listed in Table 2-2 to complete Lab 2. 

Table 2-2
Software Required for Lab 2
	Software
	Location

	Lab 2 student worksheet
	Lab02_worksheet.docx (provided by instructor)



Working with Lab Worksheets
Each lab in this manual requires that you answer questions, create screen shots, and perform other activities that you will document in a worksheet named for the lab, such as Lab02_worksheet.docx. It is recommended that you use a USB flash drive to store your worksheets, so you can submit them to your instructor for review. As you perform the exercises in each lab, open the appropriate worksheet file, fill in the required information, and save the file to your flash drive. 
After completing this lab, you will be able to:
Complete the initial setup tasks required on a newly installed server
Convert a Windows Server 2012 R2 interface from GUI to Server Core and back again 
Add roles and features using the wizard and Windows PowerShell
Estimated lab time: 50 minutes
	Exercise 2.1
	Completing Post-Installation Tasks

	Overview

	In this exercise, you complete the tasks necessary to set up a server on which Windows Server 2012 R2 has just been installed.

	Mindset                                                                                                                                                                                                                                            
	When you purchase a server from an original equipment manufacturer (OEM) with Windows Server 2012 R2 installed, the factory runs a program called Sysprep.exe that prepares the server for distribution by erasing all the user-specific information on the system.

	Completion time
	20 minutes



1.	Select SERVERB, on which Windows Server 2012 R2 has just been installed. The Settings page appears, displaying the server’s Region and Language options.                                                                                                                                                                                                                   
2.	Click Next to accept the default values for the Country and Region, Language, and Keyboard Layout parameters. Another Settings page appears, displaying the server’s license terms.
3.	Click I accept. Another Settings page appears. In the Password and Reenter password text boxes, type Pa$$w0rd and click Finish. The Windows security page appears, showing the time. 
4.	Click Ctrl+Alt+Delete and, in the Password text box, type Pa$$w0rd and click the right arrow. The system logs on the Administrator user and the Server Manager console appears.
5.	In the left pane, click Local Server. The Properties tile appears in the right pane.
6.	Click the Time Zone value. The Date and Time dialog box appears (see Figure 2-1).
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Figure 2-1
The Date and Time dialog box 

7.	Click Change Time Zone, if necessary. The Time Zone Settings dialog box appears.
8.	In the Time Zone drop-down list, select the (UTC -05:00) Eastern Time (US & Canada) time zone and click OK. 
	Question1  
	Why must you set the time zone to Eastern time, even if that is not where you are currently located?



9.	Click OK to close the Date and Time dialog box.
10.	Click the Ethernet value. The Network Connections dialog box appears.
11.	Right-click the Ethernet connection and, from the context menu, select Properties. The Ethernet Properties sheet appears. 
12.	Double-click Internet Protocol Version 4 (TCP/IPv4). The Internet Protocol Version 4 (TCP/IPv4) Properties sheet appears.
13.	Select the Use the following IP address option and, in the text boxes, type the following values:
IP address: 10.0.0.2
Subnet mask: 255.255.255.0
Default gateway: Leave blank
14.	Select the Use the following DNS server addresses option and, in the text boxes, type the following values:
Preferred DNS server: 10.0.0.1
Alternate DNS server: Leave blank
15.	Click OK to close the Internet Protocol Version 4 (TCP/IPv4) Properties sheet.
16.	Click OK to close the Ethernet Properties sheet.
17.	Close the Network Connections window.
18.	In the Properties tile, click the Computer name value. The System Properties sheet appears.
19.	Click Change. The Computer Name/Domain Changes dialog box appears (see Figure 2-2).
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Figure 2-2
The Computer Name/Domain Changes dialog box 

20.	In the Computer name text box, type SERVERB.
21.	Select the Domain option and, in the Domain text box, type adatum.com and click OK. The Windows Security dialog box appears.
22.	In the User name text box, type Administrator.
23.	In the Password text box, type Pa$$w0rd and click OK. A Welcome to the adatum.com message box appears.
24.	Click OK. A message box appears, prompting you to restart the computer.
25.	Click OK.
26.	Click Close to close the System Properties dialog box. Another message box appears, prompting you to restart the computer.
27.	Click Restart now. The system restarts.
28.	Log on to SERVERB using the Administrator account and the password Pa$$w0rd. When Server Manager opens, click Local Server in the left pane, take a screen shot of the Properties window by pressing Alt+Prt Scr, and then paste it into your Lab 2 worksheet file in the page provided by pressing Ctrl+V. Your screen shot should show the parameters you modified during this exercise.
End of exercise. You can leave the windows open for the next exercise.
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	Exercise 2.2
	Adding Roles and Features

	Overview

	In this exercise, you use the Add Roles and Features Wizard to install additional components to a server running Windows Server 2012 R2.

	Mindset
	One of the most basic tasks that administrators perform when setting up a server is to install the roles and features providing the software the server needs to perform its basic functions. 

	Completion time
	10 minutes



1.	On the SERVERB computer, which has the Server Manager console open, select Manage > Add Roles and Features. The Add Roles and Features Wizard appears, displaying the Before you begin page.
2.	Click Next. The Select installation type page appears.
3.	Leave the Role-based or feature-based installation radio button selected and click Next. The Select destination server page appears.

	Question2  
	How can you install these same roles and features on SERVERB by using tools on SERVERA?



4.	Click Next to accept the default local server. The Select server roles page appears. 
5.	Select the Print and Document Services check box. The Add features that are required for Print and Document Services? page appears.
6.	Click Add features. 
7.	Select the Web Server (IIS) check box. The Add features that are required for Web Server (IIS)? page appears.
8.	Click Add features. 
9.	Click Next. The Select features page appears. Select the following check boxes:
· Group Policy Management
· Internet Printing Client
· Windows Server Backup
10.	Click Next. The Print and Document Services page appears.
11.	Click Next. The Select role services page appears.
12.	Click Next. The Web Server Role (IIS) page appears.
13.	Click Next. The Select role services page appears.
14.	Click Next. The Confirm installation selections page appears.
15.	Click Install. The wizard installs the selected roles and features.
16.	Click Close.
	Question3  
	How would the installation of the roles and features selected in this exercise differ if the server was running Windows Server 2008 R2?



	Question  4
	How can you prove that the Web Server (IIS) role is installed on the server?



End of exercise. You can leave the windows open for the next exercise.

	Exercise 2.3
	Converting the GUI Interface to Server Core 

	Overview

	Windows Server 2012 R2 enables you to convert a server installed using the full graphical user interface to one that uses Server Core. This enables administrators who are less familiar with the Windows PowerShell interface to install and configure a server using the familiar GUI tools, and then convert it to Server Core to minimize hardware resource utilization.

	Mindset
	What advantages does Server Core provide over the full Windows Server 2012 R2 interface?


	Completion time
	10 minutes



1.	On the SERVERB computer, which has the Server Manager console open, select Manage > Remove Roles and Features. The Remove Roles and Features Wizard appears, displaying the Before you begin page.
2.	Click Next. The Select destination server page appears.
3.	Click Next to select the local server. The Remove Server Roles page appears.
4.	Click Next. The Remove features page appears.
5.	Scroll down in the list and expand the User Interfaces and Infrastructure feature (see Figure 2-3).
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Figure 2-3
The Remove features page

6.	Clear the check box for the following component:
· Graphical Management Tools and Infrastructure
7.	The Remove features that require Graphical Management Tools and Infrastructure dialog box appears.
8.	Click Remove Features. Confirm that the Server Graphical Shell checkbox was also cleared.
9.	Click Next. The Confirm removal selections page appears.
10.	Select the Restart the destination server automatically if required check box and then confirm the selection with Yes. Click Remove. The Removal progress page appears as the wizard uninstalls the feature.
11.	Click Close. When the removal is completed, the computer restarts.
12.	Log on to SERVERB using the Administrator account and the password Pa$$w0rd.
13.	Take a screen shot of the Server Core interface by pressing Alt+Prt Scr and then paste it into your Lab 2 worksheet file in the page provided by pressing Ctrl+V. 

End of exercise. You can leave the windows open for the next exercise.

	Exercise 2.4
	Using Desired State Configuration 

	Overview

	Windows Server 2012 R2 enables you to deploy system configurations using Windows PowerShell scripts.

	Mindset
	How do you use the Windows PowerShell ISE interface?

	Completion time
	10 minutes



1. Logon to ServerC using the adatum\Administrator account and the password Pa$$w0rd. 
2.	In Server Manager, from the Tools menu, select Windows PowerShell ISE. The Windows PowerShell ISE console appears.
3.	On the View menu, select Show Script Pane. The script pane appears.
4.	In the script pane, type the following script precisely as shown:
Configuration CompanyWeb
{
   Node "ServerC"
   {
      WindowsFeature InstallIIS
      {
          Ensure = "Present"
          Name = "Web-Server"  
      }
   }
} 
5.	From the File menu, select Run. The script appears on the console pane. 
6. 	In the console pane at the PS prompt, type CompanyWeb and press Enter. The tool creates an MOF file in a subdirectory called CompanyWeb, as shown in Figure 2-4.
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Figure 2-4
Running a DSC script

7.	At the PS prompt, type the following command to execute the configuration and press Enter:
Start-DscConfiguration –Wait –Verbose –Path .\CompanyWeb
8.	Take a screen shot of the Windows PowerShell ISE console showing the results of the configuration by pressing Alt+Prt Scr and then paste it into your Lab 2 worksheet file in the page provided by pressing Ctrl+V. 
End of lab. You can log off or start a different lab. If you want to restart this lab, you’ll need to click the End Lab button in order for the lab to be reset.
	Lab Challenge
	Using the Server Core Interface

	Overview

	After completing Exercise 2.3, the SERVERB server is left in the Server Core interface. Users must work from the command line to perform administrative tasks.

	Mindset
	Microsoft now recommends Server Core as the default installation option for Windows Server 2012 R2. Users should become familiar with the basic command prompt and Windows PowerShell tools, because it might not be practical to install the GUI whenever additional server configuration is required.

	Completion time
	10 minutes



To complete the challenge, you must specify the commands you would use in the Server Core Windows PowerShell interface to uninstall the roles and features you installed in Exercise 2.2 and convert the system back to the full GUI interface.
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